Changeset 749 in openpam


Ignore:
Timestamp:
Jan 13, 2014, 9:26:25 PM (7 years ago)
Author:
Dag-Erling Smørgrav
Message:

Update the way we extract the pkg version and ABI to match pkg 1.2.

Submitted by: bapt@…

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/mkpkgng.in

    r739 r749  
    7070# Determine pkgng version and ABI
    7171#
    72 pkgver=$(pkg -vv | awk '$1 == "Version:" { print $2 }')
     72pkgver=$(pkg -v)
    7373[ -n "$pkgver" ] || error "Unable to determine pkgng version."
    74 pkgabi=$(pkg -vv | awk '$1 == "ABI:" { print $2 }')
     74pkgabi=$(pkg config abi)
    7575[ -n "$pkgabi" ] || error "Unable to determine package ABI."
    7676
Note: See TracChangeset for help on using the changeset viewer.